Try Free

System Requirements for Custom Installation Package on Windows

  1. OS / Platform

    Windows 7, 8, 8.1, 10, Vista, XP;

    Windows Server 2012, 2008, 2003

  2. Java SDK

    Java SDK 8. You can download it at

    The link above points to the latest release of JDK 8.

  3. Apache Tomcat

    Tomcat 7 or higher

    You can download it at

    NOTE: It is strongly recommended to install Tomcat into a directory which name and path do NOT contain spaces.

  4. Database

    actiTIME Manual installation package supports both MS Access and MySQL databases.

    • MS Access

      Microsoft Data Access Objects(DAO) 4.0 or later.

      Usually, it is a part of Windows and is already installed. But if not, you can install Microsoft DAO as a part of Microsoft Jet 4.0 Database Engine as described at

      We strongly recommend that you choose the MS Access database only if the expected number of actiTIME users is less than ten (10). Otherwise, please consider using the MySQL database platform to avoid performance degradation and collisions when updating data.

    • MySQL

      MySQL 5.x or higher

      You can download a MySQL installation package from

    • MariaDB

      MariaDB 10.0 or higher

      Download the package at